Как сделать WI-FI камеру видеонаблюдения за 1200 рублей

wifi-webcamЦель: с минимальными затратами сделать беспроводную web камеру с доступом по wi-fi.

За основу возьмем роутер TP-LINK TL-MR3020 — 850 руб. и  web камеру Logitech С100 — 350 руб.

Итак, что мы имеем:

Роутер TP-LINK TL-MR3020:
TL-MR3020

  • процессор  – Atheros AR9331 400 МГц
  • ethernet  10/100 Мбит/с
  • USB 2.0
  • Wi-Fi 2,4 ГГц, до 150 Мбит/с
  • ОЗУ 32 МБ
  • флэш 4 МБ
  • размер 6×6 см
  • питание 5 вольт от  mini-USB разъема

Webcam logitech c100
logitech c100

  • 0.30 миллиона пикселей
  • максимальное разрешение 640×480
  • поддерживает вывод в MJPEG
  • USB 2.0

 

Устанавливаем open-wrt на TP-LINK TL-MR3020

Заходим через www интерфейс на  192.168.0.254. По умолчанию пользователь и пароль: admin admin.

Скачиваем open-wrt


http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
и устанавливаем на роутер.

После установки  open-wrt  IP адрес роутера меняется на 192.168.1.1, заходим telnet’ом

telnet 192.168.1.1

задаем пароль root’а командой passwd

После этого можно подключаться по ssh:

ssh 192.168.1.1 -l root

Настраиваем сеть

Меняем ip адрес и настраиваем выход в интернет — устанавливаем шлюз и dns.

Редактируем файл /etc/config/network

vi /etc/config/network

Приводим его к следующему виду:

config interface loopback
        option ifname  lo
        option proto   static
        option ipaddr  127.0.0.1
        option netmask 255.0.0.0

config interface lan
        option ifname  eth0
        option type    bridge
        option proto   static
        option ipaddr  192.168.1.123
        option netmask 255.255.255.0
        option gateway 192.168.1.1
        option dns     192.168.1.1

Перезапускаем сеть:

/etc/init.d/network restart

Теперь IP адрес роутера 192.168.1.123.

Устанавливаем пакет с модулями ядра linux

Пакеты устанавливаем при помощи opkg, выполняем команды:

opkg update
opkg install kmod-video-uvc

за собой этот модуль вытянет остальные необходимые пакеты с модулями ядра linux: kmod-i2c-core, kmod-video-core,  kmod-input-core, kmod-video-videobuf2

Подключаем камеру к usb и проверяем все ли хорошо, выполнив команду dmesg

[  236.860000] Linux video capture interface: v2.00
[  237.070000] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0817)
[  237.110000] input: UVC Camera (046d:0817) as /devices/platform/ehci-platform/usb1/1-1/1-1:1.0/input/input0
[  237.120000] usbcore: registered new interface driver uvcvideo
[  237.130000] USB Video Class driver (1.1.1)

Устанавливаем mjpg-streamer на TL-MR3020

Опять воспользуемся opkg:

opkg install mjpg-streamer

этому пакету необходимы  libjpeg  libpthread,  opkg их установит автоматически.

Настраиваем mjpg-streamer

Редактируем конфигурационный файл:

vi /etc/config/mjpg-streamer

Пример конфигурационного файла для mjpg-streamer:

option enabled     1
option device      /dev/video0
option resolution  320x240
option fps         10
option www         /www/webcam
option port        8080

Мне удалось получить 12  кадров в секунду (fps) с разрешением 320×240, при этом загрузка процессора достигала 65%. Если увеличить fps  или разрешение то изображение сбивается.

 Настройка Wi-Fi на TP-LINK TL-MR3020

Для того что бы роутер работал как точка доступа достаточно удалить одну строчку в файле /etc/config/wireless:

option disabled 1

Ну и кончено надо задать свои имя сети(ssid) и пароль(key) для доступа:

option ssid        SkyNet       #имя
option key         terminator   #пароль

Если же надо что бы роутер подключался к существующей Wi-Fi сети то  надо перевести его в режим клиента (sta)

Для этого меняем /etc/config/network:

config interface 'loopback'
        option ifname    lo
        option proto     static
        option ipaddr    127.0.0.1
        option netmask   255.0.0.0

config interface wifi_sta
        option ifname    wlan0
        option proto     static
        option ipaddr    192.168.1.123
        option netmask   255.255.255.0
        option gateway   192.168.1.1
        option dns       192.168.1.1

config interface lan
        option proto     static
        option ipaddr    192.168.2.2
        option netmask   255.255.255.0

а так же /etc/config/wireless

config wifi-device  radio0
        option type        mac80211
        option channel     auto
        option hwmode      11ng
        option phy         phy0

config wifi-iface 
        option device      radio0
        option network     wifi_sta
        option mode        sta
        option ssid        SkyNet
        option encryption  psk2
        option key         terminator

 

Перезапускаем сеть:

/etc/init.d/network restart

И, вуаля, можно заходить на http://192.168.1.123:8080

Про дополнительные настройки mjpg-streamer‘а и способы просмотра видео можно почитать тут: Делаем из компьютера IP WEB камеру слежения.

 

Запись опубликована в рубрике Использование linux с метками , , , . Добавьте в закладки постоянную ссылку.

87 комментариев: Как сделать WI-FI камеру видеонаблюдения за 1200 рублей

  1. Алексей говорит:

    А возможен удаленный просмотр камеры? То есть, у меня есть свой магазинчик и я хочу поставить себе камеру с роутером и необходимо просматривать в офисе в другой части города. Возможно как описано выше подключить роутер mr3020 к существующей сети моего магазинчика и перенаправить порт 8080 на ip адрес mr3020 в основном роутер дающей интернет по всему магазину И заходя на на внешний статический ip адрес моего магазинчика я увижу картинку?

  2. Артём Двинин говорит:

    Алексей,
    Да, удаленный доступ к камере будет работать.

  3. Дмитрий говорит:

    mjpg-streamer может забирать изображение с IP камер?
    Как это реализовать?

  4. Артём Двинин говорит:

    Дмитрий, mjpg-streamer запускается на роутере, и дает возможность получить доступ по сети (в том числе и через интернет) к web-камере, подключенной по USB к роутеру.
    IP камеру к mjpg-streamer’у подключать не пробовал.

  5. Дмитрий говорит:

    Это понятно.
    Кстати, почему именно mjpg-streamer?
    Почему не gstreamer, у него возможностей больше.
    Пробую gstreamer использовать, но при запуске, даже без параметров, ругается что не может загрузить плагины. Версия там, конечно, урезанная, не понятно на что именно ругается. Похоже, придеться полностью пересобирать самостоятельно его с дебагом.
    Есть еще вопрос, хаб какой лучше использовать? Купил дешевый, за 150р. AirTone. включаю в него флэшку и начинаются проблемы, похоже нужен другой хаб или с внешним питанием.

  6. Артём Двинин говорит:

    Использовал mjpg-streamer потому что он заточен под системы с небольшим объёмом памяти и слабым процессором и т.к. он заработал из «коробки» пока ничего другого не пробовал.

    А какой USB-хаб лучше, посоветовать не могу, у меня d-link dub-104, но сейчас такие уже не делают.

  7. Serega говорит:

    Такая система годится ТОЛЬКО для просмотра онлайн, но никак не в качестве охранной системы. Поясняю: подключил это к NAS как IP камеру и вижу, что сигнал тревоги срабатывает каждые 10-15 минут. Дело в том, что периодически проскакивают или помехи, или на доли секунды изображение пропадает и подглючивает, и этого хватает для срабатывания сигнализации. Но когда темно, то всё нормально. Вобщем долго мучался, и по кабелю, и по вайфай подключал, частоту кадров меня… Безрезультатно. Купил нормальную IP камеру в итоге. А это так, баловство и только…

  8. Артём Двинин говорит:

    Serega, cпасибо за комментарий. Не могли бы вы описать поподробнее что делали, какие программы использовали, с какими настройками? Мне кажется, что проблему с ложными срабатываниями можно решить путем настройки/допиливания софта.

  9. Игорь говорит:

    А камеры большего разрешения поддерживаются?
    А если делать отдельные снимки, можно ли получить их в большем разрешении?

  10. Артём Двинин говорит:

    Игорь, с камерой Logitech C270 HD получал снимки 1280×720, с этой камерой и видео с таким-же разрешением идет.

  11. mike говорит:

    а как запустить mjpg-streamer?

    я все делал пошагово как тут описано, но походу тут то ли не до конца описано, то ли еще что…

  12. Артём Двинин говорит:

    Должен сам запускаться при подключении web-камеры. А почему Вы решили что mjpg-streamer не запущен?

  13. mike говорит:

    зашел через веб-интерфейс и посмотрел в списке процессов

  14. Артём Двинин говорит:

    для запуска попробуйте выполнить /etc/init.d/mjpg-streamer start
    или
    /usr/bin/mjpg_streamer -i "input_uvc.so -d /dev/video0 --fps 10 -r 320x240" -o "output_http.so -w /www/webcam/"

  15. mike говорит:

    удалось запустить вот такой строкой:

    mjpg_streamer -i "input_uvc.so -d /dev/video0 -r 352x288 --fps 5 -q 80" -o "output_http.so -w /www/webcam/"

    по адресу устройства с портом, указанном в файле конфигурации теперь отображается веб-интерфейс стримера.

    но к сожалению картинка с камера при любом способе воспроизведения разваливается на 3-8 фрагментов, которые постоянно прыгают влево-вправо, типа так: http://prntscr.com/13xhg6, хотя при подключении напрямую к компу все нормально. С этим можно что-нибудь сделать или это просто камера неправильная?

  16. Артём Двинин говорит:

    У меня при запуске такой же командой на роутере в web интерфейсе нормальная картинка.
    А какую камеру подключили? И параметр -q 80 что задаёт?

  17. mike говорит:

    -q это уровень качества jpg в процентах, без этого параметра mjpg-streamer у меня не запускается

    камера вот такая CBR CW808M

  18. Артём Двинин говорит:

    А можете прислать лог, который выводится в консоль при запуске mjpg-streamer

    И ещё одна мысль, поставить не самую последнюю версию (snapshot), а релиз-кандидат
    http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
    может в самой последней версии разработчики openwrt что-то накосячили

  19. mike говорит:

    камера начинает устойчиво работать в разрешении 256 × 192 (даже с частотой 30 кадров в секунду). Возможный ответ я нашел вот тут http://v2.blogdoch.net/2012/06/06/wusel-174344/
    там к первому видеопримеру в котором такие же помехи как у меня высказано предположение, что камера во всех режимах может выдавать только 30 кадров в секунду. Ну и впечатляющий второй видеопример в разрешении 1280×720 и 5 кадров в секунду с вебкой Logitech C270 HD . Похоже все дело в модели вебки, не стоило пытаться любой ценой уложиться в 1200 =)
    Надо было брать камеру подороже/получше. А то эта мало того то работает неустойчиво, так и если попытаться запустить в максимальном разрешении, через пару секунд роутер ребутается вообще.

  20. Артём Двинин говорит:

    Спасибо за комментарии, может кому пригодятся :)
    Кстати, надо будет попробовать подключить Logitech C270 HD.

  21. mike говорит:

    Попробовал c270 — офигенно!
    С незначительными артефактами работает в разрешении SXGA (1280 x 960) и 25 кадров в секунду. На 5 кадрах в секунду так и вообще все идеально.
    В общем рекомендую, не экономьте на веб-камере!

  22. Георгий говорит:

    Спасибо большое за инструкцию! С камерой С270 все работает!

    Однако вот пара вопросов, ответьте, пожалуйста, как последнему чайнику:

    Автоматически камера не включается при включении роутера. Удалось ее запустить командой

    /usr/bin/mjpg_streamer -i "input_uvc.so -d /dev/video0 —fps 10 -r 320×240" -o "output_http.so -w /www/webcam/"

    (как рекомендовали в комментах). Однако при закрытии Putty камера сразу выключается, видео дальше не транслируется.

    1. Можно ли сделать так, чтобы камера запускалась и видео начиналось автоматически при включении роутера?
    2. Как это сделать? (Пожалуйста, пошагово, для юзеров, которые незнакомы с Unix/Linux и т.д. — прямо что конкретно надо делать, это ведь многим пригодится!)

    Большое спасибо еще раз!

  23. Артём Двинин говорит:

    Ага, я тоже попробовал подключить Logitech C270 HD. Отличная камера, и не такая и дорогая, в Питере за 630 р взял. А если учесть, что цена на tp-link tl-mr3020 опустились до 700 р., то в сумме получается 1330 р. за HD wi-fi web камеру :)

  24. Артём Двинин говорит:

    Пожалуйста!
    Автоматический запуск сделать можно, и я подробно опишу как, но, уже не сегодня…

  25. Георгий говорит:

    Спасибо, будем ждать!

  26. Артём Двинин говорит:

    Проверьте, пожалуйста, есть ли в файле /etc/config/mjpg-streamer строка option enabled 1
    Для этого над выполнить на роутере команду:
    cat /etc/config/mjpg-streamer
    Если этой строки нет, или там установлен 0, то надо изменить файл, например, в редакторе vim,
    для этого надо выполнить команду:
    vim /etc/config/mjpg-streamer,
    затем нажать INSERT, ввести необходимый текст, нажать ESC, набрать :wq

    Если же с файлом /etc/config/mjpg-streamer всё в порядке, напишите, предложу другой вариант решения проблемы.

  27. Георгий говорит:

    Спасибо! Да, в этом файле действительно стоит «option enabled 0″, но проблема в том, что изменения он не запоминает!
    Делал все в точности по инструкции, также пытался ввести изменения редактором vi. Вхожу в режим редактирования, меняю 0 на 1, запоминаю изменения; пробовал и отдельно :w, а затем :q, и сразу :wq — результат один — изменения не сохраняются. При просмотре командой cat сразу после редактирования в строке option enabled снова стоит 0, если перезагружать роутер после редактирования и сохранения — то же самое.

    В чем может быть дело? Что дальше можно сделать?

    Спасибо за помощь и терпение!

  28. Георгий говорит:

    Спасибо, что отвечаете. Ну а мне нового пока сказать нечего — застрял на проблеме сохранения изменений после редактирования файла. Что посоветуете?

  29. Артём Двинин говорит:

    А другие файлы получается редактировать?

  30. Георгий говорит:

    Нет, в других тоже не сохраняет. (Пробовал в файле network.)
    Не могу понять, в чем дело, ведь до этого я нормально все редактировал и все сохранялось.
    Доступ по SSH, с логином и паролем.

  31. Артём Двинин говорит:

    А при попытке записать не появляется каких-либо сообщений?

    Далее можно
    1) проверить права доступа к файлам ls -l /etc/config/mjpg-streamer
    2) посмотреть что выводит команда mount
    3) уточнить какая у Вас сборка OpenWrt cat /etc/openwrt_release

    Пришлите, пожалуйста, что выводят вышеперечисленные команды

  32. Георгий говорит:

    Уважаемый Артем,вот что выводят эти команды:

    ls -l /etc/config/mjpg-streamer
    -rw-r—r— 1 root root 172 May 14 2013 /etc/config/mjpg-streamer

    mount

    rootfs on / type rootfs (rw)
    /dev/root on /rom type squashfs (ro,relatime)
    proc on /proc type proc (rw,noatime)
    sysfs on /sys type sysfs (rw,noatime)
    tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14472k)
    tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
    devpts on /dev/pts type devpts (rw,noatime,mode=600)
    /dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
    overlayfs:/overlay on / type overlayfs (rw,noatime,lowerdir=/,upperdir=/overlay)
    debugfs on /sys/kernel/debug type debugfs (rw,noatime)

    cat /etc/openwrt_release

    DISTRIB_ID=»OpenWrt»
    DISTRIB_RELEASE=»Bleeding Edge»
    DISTRIB_REVISION=»r36602″
    DISTRIB_CODENAME=»barrier_breaker»
    DISTRIB_TARGET=»ar71xx/generic»
    DISTRIB_DESCRIPTION=»OpenWrt Barrier Breaker r36602″

    Какие есть соображения?

  33. Артём Двинин говорит:

    Может, попробовать зашить стабильный релиз
    http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
    у меня в заметке была дана ссылка на сборку, которая каждый день обновляется, возможно, там иногда получаются глючные прошивки.

    что бы перепрошить роутер надо
    1) скопировать прошивку на роутер scp openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin root@192.168.1.1:/tmp
    2) зайти на роутер, и выполнить mtd -r write /tmp/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin firmware

  34. Георгий говорит:

    Артем, простите,

    а куда я должен положить файл прошивке у себя на компьютере?
    То есть, сначала надо скачать прошивку по ссылке, а куда ее положить, чтобы скопировать на роутер?
    И еще: у меня адрес роутера 192.168.2.222 , правильно ли я понимаю, что в первой команде в конце в этом случае должен стоять этот адрес вместо 192.168.1.1 ?
    Настройки после перепрошивки должны сохраниться или надо будет все по-новой? Спасибо!

  35. Артём Двинин говорит:

    Положить прошивку можно куда угодно, только надо будет в консоли перейти в ту папку или при выполнении программы scp указать путь к прошивке.
    Если Вы используете windows, то надо воспользоваться программой pscp.exe которая входит в пакет программ putty

    т.е. scp (или pscp.exe) запускается на компьютере, например
    pscp.exe C:\openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin root@192.168.2.222:/tmp

    настройки надо будет делать по-новому

  36. Георгий говорит:

    Артем, спасибо, да, все получилось! Видимо, та прошивка лажовая была, так как с этой не возникло ни одной из предыдущих проблем.
    Все работает, автоматически запускается, и качество с камерой С270 хорошее, хотя если ставить разрешение 640х480, появляются помехи. Ну тут уж ничего не поделаешь ;)
    Артем, еще раз спасибо за помощь и оперативные ответы, и желаю Вам удачи в дальнейших экспериментах!

  37. MegaForcer говорит:

    В разделе «Устанавливаем пакет с модулями ядра linux» не указано, что на этом этапе надо в роутер воткнуть провод ethernet, чтобы получить доступ в интернет.

  38. MegaForcer говорит:

    Спасибо за инструкцию по настройке роутера.
    mjpg-streamer автоматом не запускается.
    /etc/init.d/mjpg-streamer start процесс не запускает, option enabled = 1.
    Что еще может быть.

  39. Артём Двинин говорит:

    А Какая у Вас камера?

  40. MegaForcer говорит:

    У меня камера Logitech C270 HD.

  41. Артём Двинин говорит:

    Посмотрите, пожалуйста, если выполнить команду ps на роутере, есть ли там строка c mjpg-streamer?

    получается ли запустить из командной строки при помощи команды?

    /usr/bin/mjpg_streamer -i "input_uvc.so -d /dev/video0 —fps 10 -r 320×240" -o "output_http.so -w /www/webcam/"

    И самый последний вариант: перепрошить роутер стабильной прошивкой OpenWrt
    http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
    и произвести заново настройку

  42. MegaForcer говорит:

    ps — mjpg_streamer не было в процессах. Вручную запускался, камера работала. Перепрошил на новую прошивку и заново настроил — супер! mjpg_streamer запускается при включении роутера. Спасибо!

  43. Артём Двинин говорит:

    Пожалуйста! Заходите ещё :)

  44. Владимир говорит:

    С камерой логитек все работает отлично. А вот при подключении камеры SpeedLink Reflect SL-6815-SBK-01 ничего не происходит. Наверное mjpg-streamer ее не поддерживает? Что нибудь можно сделать, а то мне очень важно именно эту камеру подключить?

  45. Артём Двинин говорит:

    А определяется ли камера при подключении по USB? Что выводит dmesg? и есть ли /dev/video0?

    Если определяется то можно попробовать запустить mjpg-streamer из командной строки и посмотреть в консоли все ли ок.

  46. Ростислав говорит:

    Здравствуйте, а чем открыть open wrt? я её не могу установить, незнаю через что открыть, формат .bin не любой программой можно открыть

  47. Артём Двинин говорит:

    Доброго времени суток :) Открывать OpenWrt не нужно, его надо скачать на компьютер, а затем установить на роутер используя его WEB интерфейс.

  48. Константин говорит:

    Звук с камеры C-270 через интернет не пробовали передавать,купил 3D sound,но чего-то у меня не получилось

  49. Артём Двинин говорит:

    Нет, звук не пробовал передавать.

  50. Константин говорит:

    Хотел добавить,что у меня 3020 две с-270 тянет на этой прошивке,на другой криво было

  51. Артём Двинин говорит:

    ЗдОрово! С двумя камерами не пробовал, думал не потянет.

  52. Константин говорит:

    Вторую камеру нужно прописывать в rc.local

    mjpg_streamer -i "input_uvc.so -d /dev/video1 -r 640x480 -f 24" -o "output_http.so -w /www/webcam -p 8091"

    если первая соответственно на порту 8090

  53. Сергей говорит:

    внесите в статью:
    для тех у кого не стартует mjpg-streamer:
    прога не стартует из-за отсутствия опции сжатия
    редактируем файл /etc/init.d/mjpg-streamer
    находим где он стартует.
    добавляем опцию запуска —quality 80

  54. Артём говорит:

    Спасибо! Добавлю.

  55. стас говорит:

    Следовал вашей инструкции.
    «Настройка Wi-Fi на TP-LINK TL-MR3020″
    Настроил режим sta «Если же надо что бы роутер подключался к существующей Wi-Fi сети то надо перевести его в режим клиента (sta)»
    После этого роутер не вижу, ни через Wifi, ни при подключении на прямую по LAN.
    Прописывал в него ip 192.168.1.11.

    Можно ли как то сбросить настройки к настройкам по умочанию (как после прошивки, когда он был доступен по 192.168.1.1)?

  56. Артём говорит:

    Чтобы установить заводские настройки, надо при включении, когда начнет мигать кнопка WPS, нажать её. Тогда роутер перейдет в режим заводских настроек, что будет видно по миганию с большой частотой кнопки WPS.
    После этого к нему можно будет подключиться, используя ip 192.168.1.1. Для того чтобы отменить все изменения, которые были внесены после установки прошивки, надо выполнить команду:
    mtd -r erase rootfs_data

  57. стас говорит:

    Спасибо, Артем.
    Подключился, перенастроил.

  58. Александр говорит:

    Здравствуйте Артём, делаю всё по инструкции столкнулся с проблемой, когда ввожу opkg update, вылазит вот такая ошибка
    root@OpenWrt:~# opkg update
    Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/Packages.gz.

    opkg download
    wget: bad address ‘downloads.openwrt.org’
    Collected errors:
    * opkg_download: Failed to download http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/Packages.gz, wget returned 1.

    Подскажите в чём проблема?

  59. Артём Двинин говорит:

    Доброго времени суток, Александр.
    У вас скорее всего на роутере не настроен dns.
    для проверки, зайдите на роутер и попробуйте выполнить команду ping ya.ru
    если в ответ получите «unknown host», то надо настроить dns. Если же пинг пойдет, то причина в чем-то другом.

  60. andry говорит:

    Везде пишут что у этого tp-link-а остается очень мало свободной памяти (300k) для установки пакетов. У вас хватило? Или использовали дополнительную флешку (просто в статье об этом ни слова)?

  61. Артём Двинин говорит:

    Если ставить только mjpg-streamer то места хватит.

  62. sanek говорит:

    Сейчас в продаже mr3020 V2. Кто-нибудь пробовал? Для него это будет работать? На openwrt.org такой версии нет.

  63. Mailz говорит:

    Не могу понять в чём проблема. При любых настройках mjpg_streamer говорит:
    Unable to start capture: No space left on device
    i: Error grabbing frames

  64. Артём Двинин говорит:

    Возможно, что не хватает свободного места.

  65. Егор говорит:

    Здравствуйте сделал все по инструкции, сделал его как WiFi клиент, но теперь я не могу установить на него доп пакеты с помощью команды opkg, я к нему могу подключиться через Putty по ssh, но при вводе команды opkg update он выдает ошибку, пишет что не может подключиться к интернету.
    я так понимаю что интернет он получает от моего роутера, но не дает скачивать пакеты и видео сигнал из вне тоже не доступен.

    Эта проблема началась после того как я переделал его в «клиента», до этого я был подключен к нему по WiFi, а роутер кабелем к моему роутеру, тогда на нем был интернет (скачивал доп пакеты). сейчас даже когда подключаешь кабелем и к ноуту и к роутеру он не работает интернет как ТД.

  66. Артём Двинин говорит:

    Здравствуйте, Егор.
    Проверьте значение следующих параметров:
    option gateway 192.168.1.1
    option dns 192.168.1.1

    Вместо 192.168.1.1 должен быть указан IP адрес вашего роутера, подключенного к интернету.

  67. Егор говорит:

    Спасибо большое, работает. Был прописан неправильный dns

  68. Егор говорит:

    Подскажите пжл, если подключить хаб и еще пару камер подключить будет работать? Выше увидел комментарий что доп. камеру нужно прописать, но вот куда ее прописать я не могу понять.

  69. Артём Двинин говорит:

    Здравствуйте, Егор.
    Чтобы добавить еще одну камеру надо в файл /etc/rc.local добавать строку:

    mjpg_streamer -i "input_uvc.so -d /dev/video1 -r 640×480 -f 24″ -o "output_http.so -w /www/webcam -p 8091″
    

    где:
    /dev/video1 — символьное имя камеры
    640×480 — разрешение
    24 — кадров в секунду
    8091 — порт по которому будет доступна камера.

    будет ли работать три и более камер — не знаю.

  70. Дмитрий говорит:

    Здравствуйте!
    После редактирования network

    config interface loopback
    option ifname lo
    option proto static
    option ipaddr 127.0.0.1
    option netmask 255.0.0.0

    config interface lan
    option ifname eth0
    option type bridge
    option proto static
    option ipaddr 192.168.1.123
    option netmask 255.255.255.0
    option gateway 192.168.1.1
    option dns 192.168.1.1

    Затем /etc/init.d/network restart. роутер меняет ip, и telnet не может к нему подключиться как по IP 192.168.1.123, так и по IP 192.168.1.1 через браузер войти получается по IP . 192.168.1.123
    Соответственно дальнейшие действия произвести не могу. Как решить проблему и что с этим делать. Брандмауэр отключен.
    Спасибо.

  71. Артём Двинин говорит:

    Дмитрий, доброго времени суток.

    А Вы не устанавливали пароль командой passwd ?
    если устанавливали, то теперь по telnet не зайти, только по ssh

    что бы войти по ssh надо в linux набрать команду

    ssh  root@192.168.1.123
    

    а под windows надо воспользоваться программой putty

  72. сергей говорит:

    а Widemac SL-R7205 можно использовать для этой задумки?

  73. Артём Двинин говорит:

    Сергей, думаю что можно, на сайте openwrt во всяком случае указано, что этот роутер поддерживается.

  74. сергей говорит:

    «Редактируем файл /etc/config/network»

    не совсем понятно как это делать, подключаюсь по ssh, вижу всю информацию. как отредактировать и как сохранить?

    подключаюсь через putty

  75. Артём Двинин говорит:

    Сергей,
    Изменить файл можно при помощи редактора vi
    в командной строке набираете vi /etc/config/network
    для того чтобы разрешить редактирование нажимаете клавишу Insert.
    После того как сделаетe изменения — нажмите кнопку Escape. Затем надо набрать :wq
    файл будет записан и Вы выйдите из текстового редактора.
    Успехов :)

  76. сергей говорит:

    confnterface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config globals ‘globals’
    option ula_prefix ‘fd62:ef6b:7e9c::/48′

    config interface ‘lan’
    option ifname ‘eth0′
    option proto ‘static’
    option ipaddr ‘192.168.1.123’
    option netmask ‘255.255.255.0’
    option gateway 192.168.1.1
    option dns 192.168.1.1
    option ip6assign ’60’

    config interface ‘wan’
    option ifname ‘eth0′
    option proto ‘dhcp’

    config interface ‘wan6′
    option ifname ‘@wan’
    option proto ‘dhcpv6′

    config switch
    option name ‘switch0′
    option reset ‘1’
    option enable_vlan ‘1’

    config switch_vlan
    option device ‘switch0′
    option vlan ‘1’
    option ports ‘0 1 2 3 4′

    при таком виде после перезагрузки в роутер зайти не возможно. в сетевых настройках виднеется ip 169.254…..

    пробовал уже поразному, даже если просто 192.168.1.1 сменить на 123.

  77. сергей говорит:

    поменял ip в веб интерфейсе на 123.

    при проверке веб камеры вот это
    br-lan: port 1(eth1) entered forwarding state
    [ 136.980000] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 137.010000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
    [ 138.980000] br-lan: port 1(eth1) entered forwarding state
    [ 308.420000] Linux video capture interface: v2.00
    [ 394.400000] usb 1-1: new high-speed USB device number 2 using ehci-platform

  78. Артём Двинин говорит:

    Сергей,
    какую конфигурацию вы хотите получить? Зачем Вам ip.v6 и vlan?

  79. Сергей говорит:

    спасибо автору за помощь. расскажу о своих проблемах и решениях. Роутер использовал tp link mr 3420 так как у него процессор момощнее и вебку c270.

    все сделал проще, установил open wrt с веб интерфейсом, после чего изменил ip адрес на 123. затем установил пакет с модулями ядра linux. после чего отредактировал разрешение как указано выше, были артефакты. сменил разрешение на 1280х960 и 10 кадров все заработали отлично.

    да и главное. никак не мог зайти на 192.168.1.123:8080. на камере лампочка не загоралась.

    оказалось что если камера подключена к роутеру и его включать то нечего не работает. камеру нужно подключать после того как роутер загрузится.

  80. Сергей говорит:

    на 15 кадрах тоже отлично работает, вот только чем писать теперь? ни одна из программ для ip камер не хочет работать.

  81. Артём Двинин говорит:

    Под линуксом можно при помощи ffmpeg (avconv) записывать. А под Windows — не знаю.

  82. Рамиль говорит:

    Здравствуйте Уважаемые!
    Имеется роутер: Mikrotik 951G и имеется на руках Web-камера Logitech Webcam C525 HD
    Задача следующего характера:
    1) В частном доме круглосуточно работает роутер Mikrotik 951G с постоянным доступом в Интернет.
    2) Тип подключения РРРоЕ с динамическим внешним IP адресом
    3) DynDNS поднят есть удаленный доступ по доменному имени, на этот роутер…
    Необходимо подключить USB Web-камеру к USB порту Mikrotikа 951G и организовать удаленный доступ к этой камере из любой точки мира. по Web-у через смартфоны и другие гаджеты…
    Другие варианты (типа купи IP камеру, смени прошивку на Openwrt) не интересуют, всё таки роутерос это линукс я думаю что это все таки возможно.
    Может кто нибудь такое делал или есть задумки поделитесь пжлст идеями…

  83. Артём Двинин говорит:

    Рамиль, добрго времени суток!
    Если не ставить OpenWrt то это усложнит решение задачи.

    Но, теоретически можно собрать mjpeg-streamer под тот линукс что у Вас на роутере, также придется собрать и драйвера для USB камеры. Затем драйвера и mjpeg-streamer надо будет установить на роутер, для этого потребуется доступ к файловой системе.

    Может я ошибаюсь, но может проще купить какой-нибудь дешевый роутер, например TP-LINK TL-MR3020 к нему подключить камеру
    и соединить его с Mikrotikа 951G по Wi-Fi или Ethernet.

  84. Егор говорит:

    Здравствуйте, начал настраивать сеть, сначала настроил обычную сеть, перезагрузил сеть, начал настраивать беспроводную сеть в качестве клиента, все прописал как было написано, перезагружаю сеть и все…. сеть вообще никакая не отвечает, подключиться к роутеру не могу, такое ощущение что сеть просто вырубилась. Подскажите что можно сделать, что бы восстановить доступ к роутеру?

  85. Артём Двинин говорит:

    Здравствуйте, настройки по умолчанию можно установить по инструкции http://mainloop.ru/linux-os/openwrt-restore-mr3020.html

  86. Егор говорит:

    Сеть ведь вообще не работает, компьютер его не видит и соответственно подключиться к роутерау никак не могу

  87. Артём Двинин говорит:

    Чтобы роутер перешел в режим настроек по умолчанию сеть не нужна, достаточно кнопки.
    В этом режиме можно отменить все настройки, которые были сделаны ранее.

Добавить комментарий

Ваш e-mail не будет опубликован.

Можно использовать следующие HTML-теги и атрибуты: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>